WinSCP Error

Advertisement

Apocal
Guest

WinSCP Error

Hello, i have problem

WinSCP Error:

Could not retrieve directory listing
Illegal PORT command

Port: 21

Where is the problem?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: WinSCP Error

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
_________________
Martin Prikryl

Reply with quote

jermlove
Joined:
Posts:
1
Location:
Philadelphia, PA

I seem to have the same problem. It's strange I'm able to connect using the exact same settings on Vista Ultimate. I've tried running 4.1.9 and the same error occurs.

OS: Windows 7 Ultimate N
WinSCP Version: 4.2.5

Error log:
. 2010-02-09 17:16:50.275 --------------------------------------------------------------------------
. 2010-02-09 17:16:50.275 WinSCP Version 4.2.5 (Build 624) (OS 6.1.7600)
. 2010-02-09 17:16:50.275 Login time: Tuesday, February 09, 2010 5:16:50 PM
. 2010-02-09 17:16:50.275 --------------------------------------------------------------------------
. 2010-02-09 17:16:50.275 Session name: jermondftp@www.briosolutions.net
. 2010-02-09 17:16:50.275 Host name: www.briosolutions.net (Port: 21)
. 2010-02-09 17:16:50.276 User name: jermondftp (Password: Yes, Key file: No)
. 2010-02-09 17:16:50.276 Tunnel: No
. 2010-02-09 17:16:50.276 Transfer Protocol: FTP
. 2010-02-09 17:16:50.276 Ping type: C, Ping interval: 30 sec; Timeout: 15 sec
. 2010-02-09 17:16:50.276 Proxy: none
. 2010-02-09 17:16:50.276 FTP: FTPS: None; Passive: No [Force IP: No]
. 2010-02-09 17:16:50.276 Local directory: C:\Users\Jermond\Documents, Remote directory: /wwwroot/DNN50, Update: Yes, Cache: Yes
. 2010-02-09 17:16:50.276 Cache directory changes: Yes, Permanent: Yes
. 2010-02-09 17:16:50.276 DST mode: 1
. 2010-02-09 17:16:50.276 --------------------------------------------------------------------------
. 2010-02-09 17:16:50.326 Connecting to www.briosolutions.net ...
. 2010-02-09 17:16:50.335 Connected with www.briosolutions.net. Waiting for welcome message...
< 2010-02-09 17:16:50.350 220 Microsoft FTP Service
> 2010-02-09 17:16:50.350 USER jermondftp
< 2010-02-09 17:16:50.371 331 Password required for jermondftp.
> 2010-02-09 17:16:50.371 PASS *******
< 2010-02-09 17:16:50.394 230 User jermondftp logged in.
> 2010-02-09 17:16:50.394 SYST
< 2010-02-09 17:16:50.414 215 Windows_NT
> 2010-02-09 17:16:50.414 FEAT
< 2010-02-09 17:16:50.435 211-FEAT
< 2010-02-09 17:16:50.651 SIZE
< 2010-02-09 17:16:50.651 MDTM
< 2010-02-09 17:16:50.651 211 END
. 2010-02-09 17:16:50.662 Connected
. 2010-02-09 17:16:50.663 --------------------------------------------------------------------------
. 2010-02-09 17:16:50.663 Using FTP protocol.
. 2010-02-09 17:16:50.679 Doing startup conversation with host.
> 2010-02-09 17:16:50.686 PWD
< 2010-02-09 17:16:50.707 257 "/" is current directory.
. 2010-02-09 17:16:50.714 Changing directory to "/wwwroot/DNN50".
> 2010-02-09 17:16:50.714 CWD /wwwroot/DNN50
< 2010-02-09 17:16:50.735 250 CWD command successful.
. 2010-02-09 17:16:50.735 Getting current directory name.
> 2010-02-09 17:16:50.736 PWD
< 2010-02-09 17:16:50.756 257 "/wwwroot/DNN50" is current directory.
. 2010-02-09 17:16:50.765 Retrieving directory listing...
> 2010-02-09 17:16:50.765 TYPE A
< 2010-02-09 17:16:50.778 200 Type set to A.
> 2010-02-09 17:16:50.780 PORT 10,1,3,105,194,49
< 2010-02-09 17:16:50.800 500 Invalid PORT Command.
. 2010-02-09 17:16:50.800 Could not retrieve directory listing
. 2010-02-09 17:16:50.811 Retrieving directory listing...
> 2010-02-09 17:16:50.811 TYPE A
< 2010-02-09 17:16:50.822 200 Type set to A.
> 2010-02-09 17:16:50.824 PORT 10,1,3,105,194,50
< 2010-02-09 17:16:50.846 500 Invalid PORT Command.
. 2010-02-09 17:16:50.846 Could not retrieve directory listing
* 2010-02-09 17:16:50.846 (ECommand) Error listing directory '/wwwroot/DNN50'.
* 2010-02-09 17:16:50.846 Could not retrieve directory listing
* 2010-02-09 17:16:50.846 Invalid PORT Command.
. 2010-02-09 17:16:52.252 Startup conversation with host finished.
. 2010-02-09 17:16:52.311 Disconnected from server

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Have you tried passive mode?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Anonymous wrote:

Yeah I tried running in passive mode and still got the error.
Can you post a log file for that?
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum