transfer queue breaks at one ampersand (&) in filename

Advertisement

copycat
Joined:
Posts:
1

transfer queue breaks at one ampersand (&) in filename

hi,

the whole transfer queue is broken if there is just one file with on ampersand in its name. this is annoying if one has been spending some time to fill the queue. happens with WinSCP 4.2.6 (with SCP, SFTP is ok) under XP. even if that is a principal problem of SCP there should be a warning or the file should be skipped instead of completly breaking.

error-message in german:

SCP konnte fr den Start der bertragung nicht ausgefhrt werden. Bitte stellen Sie sicher, dass SCP auf dem Server installiert ist und die $PFAD- Variable den Pfad zu SCP enthlt. Anstatt SCP knnen Sie auch SFTP probieren.

remote server is openssh 4.4, SSH1

regards
copycat

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,542
Location:
Prague, Czechia

Re: transfer queue breaks at one ampersand (&) in filename

Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.

_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum