Topic "winscp defaults to ipv6 for localhost"

Author Message



I connected to localhost (standard SFTP) on Port 8022.
It always told me that the connection was refused while other clients worked.
With logging enabled it turned out that WinSCP tried the IPv6 adddress [::1] and aborted after that.
My service was listening on and WinSCP did not recognize it, when I didnt explicitly enter the IPv4 address.

I suppose this is a minor bug and would be delighted if you fixed this.
I also reckon that you know how a log-output of a failed disconnect looks like, so I won't provide any output Razz
Affected OS is WIndows 7 here.
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26890
Location: Prague, Czechia
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.
Martin Prikryl


sorry, but no.
I will not login and I dont want any debug versions. This was on a test VM that has already been reset anyway...

You can post new topics in this forum


What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License