Tracker Bug 1221

Improve compatibility with antiquated FTP servers, like IIS

Last modified: 2016-05-06 11:33:44

No search results available

: Improve compatibility with antiquated FTP serve... Bug# 1221
: WinSCP : Unspecified
: Core : unspecified
Status: RESOLVED : Medium
Resolution: FIXED   : Enhancement
Fixed in: 5.6.2
Description
2014-09-18 11:26

Comment #1
2014-09-22 16:25:13
1) Using CWD/SIZE/MDMT to retrieve information about file when MLST is not supported.
Comment #2
2014-09-29 15:20:26
2) Non-standard use of MDTM to modify remote file timestamp
Comment #3
2014-09-30 15:07:39
3) Autodetecting timezone difference for servers not supporting MLST command
Comment #4
2014-09-30 15:08:25
Done.
Comment #5
2014-10-30 10:47:38
Documented:
https://winscp.net/eng/docs/interoperability?rev=1414660020&rev2=1408638412&do=diff
https://winscp.net/eng/docs/ui_login_ftp?rev=1414659599&rev2=1412232982&do=diff
https://winscp.net/eng/docs/ui_login_environment?rev=1414662443&rev2=1414661571&do=diff
Comment #6
2015-01-13 14:25:04
Question related to timezone auto-detection on stackoverflow.com:
https://stackoverflow.com/a/23825190/850848
Comment #7
2015-04-29 15:42:32
Timezone part caused Bug 1324.
Comment #8
2015-07-09 15:46:08
Timezone part caused Bug 1342.
Comment #9
2015-07-10 14:25:55
Timezone part caused Bug 1343.
Comment #10
2015-10-14 09:55:49
See Bug 1366.
Comment #11
2015-12-22 16:13:25
See Bug 1249.
Comment #12
2015-12-22 16:14:11
See Bug 1209.
Comment #13
2015-12-22 16:15:42
See Bug 1380.
Comment #14
2016-01-26 09:22:06
*** Bug 714 has been marked as a duplicate of this bug. ***
Comment #15
2016-01-26 14:18:03
5.8.2: Retrieving seconds-precision timestamps using MDTM command, if the server provides them.
Comment #16
2016-01-26 14:40:58
See Bug 1395.
Comment #17
2016-05-06 11:33:44
See Bug 1424.

No search results available

Bug filters: [Pending bugs] [All bugs] [Fixed bugs]

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License