Topic "Putty prompts with "login as:" when I press CTRL+P"

Author Message
[View user's profile]

Joined: 2013-02-12
Posts: 88
This has bugged me for a long time, but now I managed to reproduce a proper scenario.
I have two saved sessions - s1 and s2. The bug shows with s2, but not s1.

1) I connect with s1, and pres CTRL+P, putty opens and goes automatically through the login process and shows me a working shell prompt. Works as expected.
2) I connect with s2, and pres CTRL+P, putty opens, but it prompts with "login as:". I have to manually enter the username, and then it logs me in and shows me the shell prompt (UNdesired behaviour).
3) (workaround) I open the login window, go to Saved sessions, select s2 and click Edit. Then I press the Login button. Putty opens and logs me in right to the shell prompt without asking me for username (desired behaviour). What I also notice is that the connection Tab name is now "myusername@ipaddress" instead of "s2".

I am pretty sure it is not about settings, because I compared s1 and s2 and except for the IP they are exactly the same. I also checked with colleagues using s1 and s2 and they don't have the issue.

Protocol used is SCP; Server is AIX 6.1
Windows 7, 64bit; WinSCP 5.1.3 (but also with previous versions)
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24759
Location: Prague, Czechia
My guess is that you have stored session named "s2" in PuTTY that does not have username saved. Then WinSCP uses the stored session, not trying to push its settings to PuTTY.

[View user's profile]

Joined: 2013-02-12
Posts: 88
Wow, you were right!
10x, I deleted it, and that worked.

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License