Topic "Uploading changes in default Editor doesn't work sometimes"

Author Message
franc
[View user's profile]
Donor
Joined: 2007-05-12
Posts: 46
Hello

this is a weird bug, I have only since the WinSCP version 5.5.2
I am on Windows XP (SP3, 32).

I use normally the multitabbed Editor EditPad Pro, version 7.3.1
Often I edit files from my SSH-connected Ubuntu Server with SFTP in this editor.

But sometimes, it happend now the second time, I wonder why the changes are not visible, but I did save them, no error message.
Reason is, that WinSCP doesn't upload it again.
So I tried with a single window editor, TedNPad, but still the same.

It will work again, I thought, when I restart WinSCP, but this is a bit annoying, because I have three WinSCP tabs and files open.
But no, this doesn't still not work, when restarted WinSCP.
I tried to upload big changes, so WinSCP should be busy a little and I can look into the Queue, there I see strange Progress completed and Transferred 0 B, after a short while Queue closed:

http://abload.de/img/clipboard-hp4592flu3m.jpg

I dont remember to have this bug on previous WinSCP versions. Could it be related to the previous bug ("fixed") with Copying files from remote side failed?

I don't think it is possible to log WinSCP, because this bug appears not often, so the logfile could be gigabytes.

Thank you.

frank
winscp-queue.jpg (11.19 KB) [Download]

Description: Queue WinSCP 5.5.2

Advertisements
franc
[View user's profile]
Donor
Joined: 2007-05-12
Posts: 46
This is a real problem.
I cannot trust to editing through WinSCP anymore.
I wonder why things not working and again this doesn't upload!

I don't know what this is, the only way then is, to delete file, and recreate it with same content. This work then a while.

What could that be?
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Thanks for your report.
I have sent you an email with a debug version of WinSCP to address you have used to register on this forum.
_________________
Martin Prikryl
franc
[View user's profile]
Donor
Joined: 2007-05-12
Posts: 46
Can you send me a version, where there is all private data in the debug log excluded?
I find a lot of things like:

[Password=A35C795D0D2E333...]

in this debug-logfile.

I guess till the bug will appear, it could take some time, and in the end, I have a debug protocol of 100 MB or more.
It will be not possible for me to surely delete all private data in this log (like I tried last time).
The log will be filled with passwords, I cannot send these out, sorry.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
I have sent you an updated debug build.
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License