Topic "Automated task fails when interactive OK"

Author Message
Jiri Hovorka


When I use WinSCP in interactive mode, everything works perfect (upload, download, file deletion).

Scripting the same task fails when uploading files in WinSCP versions 5.5.3 b4214 and 5.1.5 b3261 - log with comments is included. Transfer fails with Status code: 2, Message: 2563, Server: File not found.

I have tried put/mput with all the options explicitly (no combination worked) and setting everything in the INI file with no luck. Pitty is, that the server does not let me open console:(

Maybe I overlooked something stupid:) Can you please help?
Free beer for the help!
winscp.log (3.91 KB) [Download]

Description: a part of the log with comments

[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24759
Location: Prague, Czechia
The problem might by that you are using backslash in remote path instead of forward slash: put readme.txt .\

Last edited by martin on 2014-06-05; edited 1 time in total
Jiri Hovorka


...ohhh my! - 5 people looked into it and overlooked just one little character:)
put readme.txt ./ worked

The beer is yours - i will write to your email.

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License