Topic "Host does not exist"

Author Message
SB

Guest


Hi
Apologies if this has been asked and answered before

I successfully created a script to retrieve files from a Solaris 10 Server and was working fine. However when trying to run this script today I now receive "Host does not exist", I am unaware of any changes to my end or the server end, so effectively it has just stopped working from what I can see.

However the following run from the command line works fine

winscp.exe /console /command "option batch off" "open root:password@172.x.x.x"

But the following does not work in a script and generates the "Host does not exist" error

open root:password@172.x.x.x
I have added to the host key to the cache already

Any ideas would be appreciated
Thanks
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24512
Location: Prague, Czechia
Do you mean that when you run
winscp.exe /console /command "option batch off" "open root:password@172.x.x.x"
it works, while when you run
winscp.exe /console /script=script.txt
from the very same location, where script.txt includes command
open root:password@172.x.x.x
it does not work?

It does not make much sense.
Try to turn on logging in both cases and compare the log files as described here:
http://winscp.net/eng/docs/faq_environment
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License