Topic "How to disable automatic symlink resolution?"

Author Message
netvope
[View user's profile]

Joined: 2010-01-17
Posts: 4
When I browse to a directory containing symbolic links, WinSCP would hang for a few seconds before showing the listing. A directory with a similar number of files without any symlinks shows almost immediately. Apparently this is because WinSCP sequentially resolves each symlinks in the directory, and the network latency between me and the server is less than ideal. WinSCP display a nice little icon to indicate whether the symlink destination exists.

How can I tell WinSCP NOT to resolve the symlinks when I'm browsing the directories? I don't need to know whether the symlinks point to valid files, and I want WinSCP to show the directory to me immediately. It would be better if the user can set WinSCP to resolve symlinks on-demand (download/open/edit) rather than in-advance.

If this is not currently implemented, could you please tell me which part of the directory listing code calls the symlink resolution functions? I'm willing to make the effort to compile my own version because pausing for a few seconds every now and then is really frustrating.

Thanks!
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Please read documentation:
http://winscp.net/eng/docs/ui_login_directories
_________________
Martin Prikryl
netvope
[View user's profile]

Joined: 2010-01-17
Posts: 4
Thanks a lot! It works perfectly.

I searched through every option after logging in and couldn't find anything. I've never thought that the option could only be reached before logging in!
Yuriy

Guest


Hi, I've got a similar problem here. Let's say I wanna copy from a remote Linux machine a directory with many directories, some of them containing symbolic links to very large files. I don't need these files to be actually transferred - only the symbolic links (if it is not possible I'd prefer to skip these links at all). I tried to unset "resolve symbolic links" and exclude files by theirs weights (mask: *>70M), but these files are still copied.
What on Earth am I doing wrong?
Thanks!
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24530
Location: Prague, Czechia
Thanks for your post. This issue is being tracked already.

Regarding the mask: It is because the size of the symlink is considered, not the size of the target file.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License