Topic "Prefences>Transfer>Upload options>Set permissions not obeyed"

Author Message
[View user's profile]

Joined: 2011-01-04
Posts: 2
4.3.2 & 4.3.3

Uploading from XP box to Ubuntu box directories and files are always transferred with default permissions i.e. 755 and 644 respectively, yet I have the box checked and set to rw-rw-r-- (+x). I would like to see transferred directories and files as 775 and 664 (I would like group writeable for dirs and files).

Any advice please?
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 24755
Location: Prague, Czechia
Please post a full log file showing the problem.

To generate log file, enable logging, log in to your server and do the operation and only the operation that causes the error. For posting extensive logs you may use pastebin or similar application. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you may email it to me. You will find my address (if you log in) in my forum profile. Please include link back to this topic in your email. Also note in this topic that you have emailed the log.
Martin Prikryl
[View user's profile]

Joined: 2011-01-04
Posts: 2
Although I had changed permissions from rw-r--r-- (+x) to rw-rw-r-- (+x) in Preferences/Transfer tab, I had not changed permissions in Preferences/Transfer/Presets for the auto preset I had configured for binary transfers.

Thanks for reading.

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License