Tracker Bug 500

Pre- and post- transfer custom commands

Last modified: 2015-11-12 12:20:55

No search results available

: Pre- and post- transfer custom commands Bug# 500
: WinSCP : Unspecified
: General : unspecified
Status: RESOLVED : Medium
Resolution: FIXED   : Enhancement
Fixed in: ---
Description
2009-11-05 02:26
E.g. to:
- compress files before transfer and uncompress after (though this is quite complicated as it would involve actually changing object of the transfer)
- do anti-virus check after transfer
Comment #1
2009-11-05 02:28:10
Generally I do not see point of either of use cases:
- Compressing can be enabled on session level, at least for SSH (Though it does not help much, when transferring lots of small files)
- Majority of people have anti-virus checks enabled implicitly.
Comment #2
2009-11-05 02:28:16
https://winscp.net/forum/viewtopic.php?t=7579
Comment #3
2009-11-05 02:28:52
Also both can be automated using scripting.
Comment #4
2009-11-05 02:42:02
*** Bug 221 has been marked as a duplicate of this bug. ***
Comment #5
2009-11-21 21:32:16
Actually this cannot be automated using scripting unless Bug 510 is implemented.
Comment #6
2009-11-21 21:34:51
Well, it can be automated, but the script cannot be integrated into WinSCP GUI.
Comment #7
2009-11-21 22:23:42
See:
https://winscp.net/eng/docs/script_auto_compress_download
Comment #8
2010-12-17 09:08:09
https://winscp.net/forum/viewtopic.php?t=9126
Comment #9
2015-11-12 12:20:55
Closing as Bug 510 has been implemented.

See https://winscp.net/eng/docs/guide_custom_commands_automation

No search results available

Bug filters: [Pending bugs] [All bugs] [Fixed bugs]

Search

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License