Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Win SCP Cannot Read Remote Directory After System Refresh

I'm not sure this is WinSCP problem. Unless you can connect with other clients, but not with WinSCP, you should better seek for help elsewhere. What about

Win SCP Cannot Read Remote Directory After System Refresh

I did Google this and tried the 'simple' fixes to no avail and thought I'd ask here. Sorry for the length, but I think it is needed.

WinSCP ver 5.17.6. Just migrated my FreeNAS box from flash drives to new SSDs. I had upgraded to FreeNAS-11.3-U3.2 and run for a week with no problems. I am running a Supermicro system w 2 1G ports (+1 IPMI). Only one 1G port is connected and has a static address. This port is working fine with WinSCP. The FreeNAS box also has an Intel x520-D1 NIC (10G) card connecting via a Miktotik hub; these interfaces are on different subnets (192.168.x.0 and 192.168.y.0). The client systems are Win10-64Pro patched to the current level.

This setup has been working without problems.

After the disk refresh (same FreeNAS version)(which, FWIW, went smoothly), I could no longer connect via the 10G NIC. First I had nothing but a ping response. Then it rejected the connection. After turning on SSH in FreeNAS, it 'connects', but times out trying to read the directory.

I tried turning off the "optimize buffer" setting to no avail. I can't uncheck the "passive mode".

This is a home system and I'm running everything as root until it all works, so ownership isn't likely an issue (and it worked this way in the past). I'm guessing it is an issue somewhere in FreeNAS, but when I configured the system a few months ago, it 'just ran' so now I'm scratching my head.

Addendum: Did a little testing from another box. When I came in from system_0 for the first time since refresh, I hit "UPDATE" and had problems. When I came in from system_1, I hit 'add' and it works. Once. Then it hangs on reading the directory. And THE SAME THING happened with system_0 - worked one time then hangs...

Any thoughts?