Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review

Ian Mac

Help me please!!

Hi Martin
thanks for the reposnse and sorry about the delay in getting back to you. I actually solved the issue i had " " in the wrong place!!


Re: Help me please!!

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
Ian Mac

Hi all couple of additional 1. I have now for the base script to work in Windows 2019 but as soon as i add
open sftp://<Username>@Ipaddress/ -hostkey="ssh-rsa 2048 blahblah=" -private key="path filename.ppk" -passphrase="xxxxxxxx"

the file stops working....
Ian Mac

Help me please!!

I have a script that works perfectly the batch file is
"C:\Program Files (x86)\WinSCP\WinSCP.exe" /log="C:\concur\log\WinSCP.log" /ini=nul /script="c:\concur\sftp_concur.txt"

Call the txt file that is
open sftp://<username>:passwd@IPAddress/ -hostkey="ssh-rsa 2048 blahblah"

this has worked perfectly on Windows 2008 but i have to upgrade to Windows 2019 and just doesn't work no error just no results!!
To complicate matters i also need to use Public and Private keys i have generated these and can connect to the site using the app but i can not get this to work on script!

This should be so simple!! Please help a frustrated admin!!!
It seems to work but i get no log file update nor do i get any connection with no error