Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Prompt for proxy password when it is not specified on login dialog [SOLVED]

Good idea. Thanks for sharing it.
ehusby

Re: Prompt for proxy password when it is not specified on login dialog [SOLVED]

Today I found a working solution, swapping out PuTTY's plink.exe for TortoiseSVN's TortoisePlink.exe in the local proxy command (and dropping the -pw %pass part of the command). TortoisePlink will give me a graphical prompt for the RSA Token code upon establishing the initial connection, and at any time WinSCP needs to open a new background connection as well!! So now I can finally edit files directly on the remote system through WinSCP!

I am so happy -- today was the last day I will need to call NASA IT to have my account unlocked.:)
ehusby

Prompt for proxy password when it is not specified on login dialog

Related tracker: Bug 468 – Prompt for proxy password when it is not specified on login dialog

For my login to NASA systems, I must use an 8-digit RSA Token code as the proxy password (workflow details are all here: https://www.nccs.nasa.gov/nccs-users/instructional/using-discover/file-transfer/local-to-nccs-systems).

The NASA workflow dictates that I must update the proxy password every time I attempt to connect to their systems using WinSCP. If I forget to do this, WinSCP will automatically make many attempts to connect to the proxy in the background using the old, expired 8-digit token code. When this happens, NASA detects the many failed authentication attempts and puts a lock on my account. I have to then call up NASA IT to have them unlock my account. This has happened at least 5 times now and is very frustrating!

It would be so helpful if I could leave the proxy password field blank so that it must be entered every time I establish a new connection to the NASA system, to avert this pitfall.

On a related note, after I have connected successfully to the NASA system, I must be careful to not accidentally initiate a new background connection because it will again use the old, expired 8-digit token code when attempting to establish the background connection. This means I currently cannot edit any files on the remote computer. If I accidentally try to edit and save a file on the remote side, WinSCP will again automatically make many failed attempts to connect to the proxy, resulting in my NASA account being locked out. To avert this problem, I wish there was a setting to allow editing and saving remote files using the same connection as the main "file browsing" connection -- without needing to create a new connection in the background for the file transfer of the updated file.

Thank you so much, I really love WinSCP!