Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Working without any changes...

Funny enough without changing anything suddenly it works again.

Logfile updated in first post

Thank you for your reply. Indeed I messed up with the logfile.
In the first post I attached the correct logfiles for passive mode enabled and disabled.

When using the standard windows ftp command line client ftp.exe I can login, list directories, and upload and download files.

Re: Retrieving of directory fails after connection is established

The log file you have attached shows an invalid password. The session does not even get to the point of reading a directory. It does not correspond to your post.

Can you retrieve the directory using any other FTP client in the passive mode? Can you retrieve the subdirectories in the active mode using any other FTP client?

Retrieving of directory fails after connection is established


when trying to connect to an FTP-Server I used version 5.17.8 and it all worked fine.
Suddenly without changing the WinSCP-version it stopped working.
I installed the current 5.17.10 but same behavior.

Connecting to the ftp server with Windows-FTP perfectly works with same address, username, and password. Even uploading a file works like a charm while WinSCP suddenly has this issue.

- WinSCP: Version 5.17.8 used to work, suddenly not anymore. Installed 5.17.10, still not working
- OS: Windows 10 64 bit, current updates
- Transfer protocol: FTP with passive mode enabled
- Problem occurs with GUI (Commander) and scripting
- Error message:
--- First window:
------ Connection to ##########
------ Connected
------ Starting the session...
------ Reading remote directory...
--- Second window:
------ Lost connection.
------ Timeout detected. (data connection)
------ Could not retrieve directory listing
------ Error listing directory '##########'.

I've found several partly very old questions about this error message
but I could not find any solution for me.

My log file is attached.

Do you have any ideas about this?

When disabling passive mode, the first directory is read
after the login, but then the program does not show selected
subdirectory afterwards at all.

I'd really appreciate any kind of help.

Thank you very much!