Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

pot

Email replied. The trace files are too big, I can't send them via email. There are 7 files and when I zip them it is still 134MB in size.

Can you setup a storage for me to upload?
martin

Re: How to automatically reconnect when there's a TLS timeout error

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
pot

Re: How to automatically reconnect when there's a TLS timeout error

Still having the same problem on 5.18.3 RC, it's unable to automatically resume the connection.

I have to manually click "Retry" on the first error window. Then only on the second error window, that it can automatically reconnect.
martin

Re: How to automatically reconnect when there's a TLS timeout error

Can you try it with 5.18.3 RC? There were some related improvements.

If it does not help, please post a new log file from that version.
pot

How to automatically reconnect when there's a TLS timeout error

WinSCP Version 5.17.10 (Build 11087) (OS 10.0.18363 - Windows 10 Home)
Transfer protocol: FTP with Explicit TLS/SSL encryption
User interface: GUI Commander

I often get this error when downloading file from a particular server:



I can reconnect just fine after clicking "Retry". After that the second notification appears, but this time this notification window has a countdown timer on its button (it can automatically resume without your input). After that the download will resume without any problem.

My question is, is there any way to make it automatically retry on the first error notification? Or maybe a way to completely skip the first error notification?

I've already checked my Endurance Page settings, seems like everything is already set. But every time this error happens, I have to manually click "Retry" first (the above error notification).