Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review



No, for me there was no solution.
For me it only worked after I reset my computer and reinstalled it. Since then I didn´t have the problem anymore.
But maybe someone else has a solution for it, then it would be nice if he / she could post the solution here.

Best regards

Was there a solution?

Was there a solution to this problem i.e. when drag and drop stops working between commander local and remote windows?

OK, I didn´t see any instructions. Sorry for that.
Now I created a new log file, I started dragging between 8:49:31 and 8:49:34.
Attached there is the new log file, I made it private this time.

EDIT: One more info, I tried to move the file "index.html" from remote to local.

The debug version is not supposed to fix anything. It's for debugging the problem.

Please follow the instructions.

Do not attach trace file publicly. It contains sensitive information. Please keep this in email conversation. I've removed the log from your post.

Also, as per the instructions, I need exact time you attempted to start dragging.

I downloaded this version and started it but the problem is the same...
Find attached the ZIP file with the log file.

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.


Any suggestions what I can do in this case?
WinSCP is very important for me, so it would be good to get it working again.

Yes, I tried the other option as well. Also not working.
The dragging does not start and the mouse cursor does not change.

There's no option to disable drag&drop. Dragging within WinSCP does not involve the drag&drop shell extension. So that's should not be related either. Though in any case, did you try the other option (temporary folder)?

Does the dragging start at all? (= does the mouse cursor change when you start dragging)? Or is it the dropping part that does not work?


I tried to drag & drop files / folders within WinSCP from local panel to remote panel and vice versa. Nothing is working.
I shutdown my computer every day and also restarted it a few times.

Now I tried to drag & drop files from Windows Explorer to the remote panel in WinSCP, this is working. But when I try to drag & drop files from remote panel in WinSCP to Windows Explorer, this is not working.
Maybe there is a keyboard shortcut in WinSCP to deactivate the drag & drop feature and I hit that by mistake?

Re: Drag & Drop stopped working (WinSCP 5.17.10)

Where exactly do you drag the files from and to?
From Windows Explorer to WinSCP? Or the other way? Or within WinSCP (from local panel to remote or that other way)? Does any of these work? Or none?
Did you restart your machine?

Drag & Drop stopped working (WinSCP 5.17.10)

Hi @all,

I have the problem that from one day to another the drag & drop function in WinSCP is not working anymore. I didn't change anything in the settings.
When I open the settings in WinSCP and select the "Drag & Drop" menu, it shows me that the shell extension is installed but not running. Yesterday it was installed AND running. But drag & drop is not working, it doesn't matter if the extension is running or not.
I already tried to uninstall the program and reinstall it but this didn´t help. I also tried to uninstall the current version (5.17.10) and install a prior version but this also didn´t help.
I saw that there are already some similar topics in this forum but there was no solution.
I need the program nearly every day because I´m managing a dedicated root server with a few public game servers.
On my computer I have Win 10 x64 and all updates installed.
Does anybody know how I can solve this problem?

Best regards