Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


The latest version of WinSCP can browse the Windows drives (that have a letter associated, like C: or X:) and UNC paths (like \\TSCLIENT\C).
The old version of WinSCP you have does not support the UNC paths.
But you can map the UNC path to a letter in Windows and then you will be able to use your old version of WinSCP.

Hello Martin,

This may be a language/technical abuse, but since I see the disk in the "Network" tab and can browse and see my personal folders there, it means that the disk mapping is functional and that the intermediate server sees the disk.

Technically, if the mapping with CyberArk hadn't worked, I wouldn't be able to see this "\\tsclient\C" disc in the "Network" tab and would see absolutely nothing. (cf "HOME2.PNG" in the discussion above).

So are you saying that the mapping doesn't work because it is not displayed in "This PC" ?

Thank you for your help and clarification, unfortunately I am not a system expert ...

mviruser wrote:

It seems that the mapping is correct but not displayed in WinSCP then.

What do you mean by mapping is correct? Can you see the mapped drive anywhere else, when you do not see it in WinSCP? In Windows File Explorer? In another other application? So far this does not seem to be WinSCP issue.

Hi Martin,

That's a good point. When, it works, I'm able to see the drives mapped (cf functional_test). But, when it doesn't work, I'm stuck with the "X:\SWAP" and this behaviour is identical on my 4 servers. (cf nonfuctional_test)

At the same time, I add the logs from CyberArk for the session associated with the non-functional test:
[29/06/2021 | 17:34:43] |  ::  | PSMDU031I Mapping terminal services drives

[29/06/2021 | 17:34:43] |  ::  | PSMDU025I Searching for available drive letter
[29/06/2021 | 17:34:43] |  ::  | PSMDU027I Found available drive letter [Y:]
[29/06/2021 | 17:34:43] |  ::  | PSMDU026I Trying to map teminal services drive [\\TSCLIENT\C]
[29/06/2021 | 17:34:43] |  ::  | PSMDU028I Drive [Y:] mapped to [\\TSCLIENT\C]

It seems that the mapping is correct but not displayed in WinSCP then.

Any idea ? Does it come from WinSCP or a parameter to configure somewhere ?

Your screenshot does not show any mapped drive. Mapped drives are under the "This PC", which is collapsed on your screenshot.

Thanks for your reply :)

Yes it works for any application. For example, we use the mapping of local drives to connect to web administration platform on Google Chrome and we never have an issue with it.

In the following screens, you can see :
1. That the drives are not displayed in the drop-down list
2. That the drives are well mapped through the Windows File Explorer of WinSCP

But as I said previously, the drives are not displayed in the drop down list and we cannot add the drives once the process is launch because UNC Path are not supported.

Re: WinSCP with CyberArk - Unable to see the local drives

So can you browse the mapped drives using any application? Can you see the mapped drives in Windows File Explorer? Post a screenshot.

WinSCP with CyberArk - Unable to see the local drives


After a lot of research on CyberArk and WinSCP forum, I'll try my luck on the WinSCP forum because I still haven't found any solutions yet.

When I connect using the PSM-WinSCP connector on CyberArk, the local disks of the user workstation are not displayed all the time (it works randomly).

When it doesn't work, no disc from the PSM wants to show and I have the following correspondence:

Nevertheless, I am 100% sure that the local drives are mapped because :
– I can see that the process worked in the CyberArk logs :
PSMDU028I Drive [Y:] mapped to [\\TSCLIENT\C]

– When I browse my filesystem directly from WinSCP, I can see my disks in the "Network" tab (and not in the directly accessible drop-down list from the home page)

For the second point, unfortunately the version of WinSCP supported by CyberArk is 5.9.5 and when I try to add the UNC path (\\tsclient\c) directly, I have the following error : "UNC paths are not supported".

The problem of adding UNC Path seems to be solved from version 5.15 but it seems to me that it does not work through CyberArk yet.

So, my questions are :
- Has anyone faced this problem before and have a solution?
- Is there a way to switch from a UNC Path to a path recognized by the software in version 5.9.5?

NB : I am currently in troubleshooting with CyberArk support but we haven't find a viable solution for now.