Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Yes, I can reproduce the issue in the latest build that you sent. It didn't generate a log file though, not sure if it was intended to.

Thanks. I have sent you another build for testing.

After this error occurred I opened a new session on a different site and on trying to download over FTP to a different directory, which had opened fine in the browser, I got the following error:
WinSCP was not able to detect folder, where the dragged file(s) was dropped

On restarting the application this download worked fine. It seems related to me.

Thanks Martin,

I tried replicating the issue with the debug version but it worked perfectly. The 'dist' directory reappeared in the navigation panel correctly and could be clicked on again in the files panel.

I tried the same operation again with my installed version and the bug persisted.

I've attached the log file anyway.

Re: Can't navigate to directory after deleted and re-created

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Can't navigate to directory after deleted and re-created

WinSCP v5.19.1
Win 10 Pro build 19043

In a project I have a dist directory that I FTP to the server with WinSCP. When the project is built the dist directory is deleted and recreated with the build files.

If this directory is currently selected in WinSCP then it does not reappear in the file browser when recreated and cannot be navigated into when clicked on in the navigation pane.

I recorded a screencast to demonstrate the issue: