Post a reply

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Turn off Optimize connection buffer size

@Ed: Please post a log with "Optimize connection buffer size" turned off.
Ed

Re: Turn off Optimize connection buffer size

Could it be that there are too many files to load on the server directory you are trying to connect to? The buffer settings seemed to work for me for about a month, then it stopped working with the same message.
martin

Re: Turn off Optimize connection buffer size

@HackTheDev: Sorry, your post does not include enough information.

Please read how to ask for support or report bugs efficiently, so others can help you.
HackTheDev

Re: Turn off Optimize connection buffer size

This is not working for me
samr

For some reason, the site I connect to doesn't work well with the "Optimize connection buffer size" enabled, and whenever I had that on while downloading files larger than a few megabytes, I'd get this error: Server unexpectedly closed network connection.

Fortunately, I found how to turn it off and (in the GUI version at least) all my transfers are successful. On the contrary, in batch mode from a script file, even after setting -rawsettings SendBuf=0 appended to the open command, the connection will "unexpectedly close" on files larger than a few megabytes.

Does SendBuf=0 completely turn off the feature as the GUI checkbox does?

Thank you.
kdejarnet

Re: Turn off Optimize connection buffer size

I've been trying to get this to work in a SSIS 2005 Execute Process Task but keep getting the message "Unknown command -rawsettings"

I'm using it as the first line of my script like so: -rawsettings SendBuf=0

Is there a different way I should be using this?

Thanks, Keith
kdejarnet

Awesome. Thanks.
kdejarnet

Turn off Optimize connection buffer size

Is there a way to do this in the script? I tried using "option optimize connection buffer size off" but this is throwing an error.

Thanks.