Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Following up on XML logging

Thank you for that piece of information – I had (I thought) read the documentation carefully – if that was noted I must have missed it. It would be helpful, if it isn't there for a future revision of the documentation to note what the XML log does and does not capture, I think this new information explains a good portion of the issue we are seeing.

For now, I will work with our team to come up with an acceptable alternative. If there are plans to collect background transfers in the XML log in a future revision, I will see if we wish to change back to using XML logs when we discover the new capability.

Re: cannot upload log files

william_b_noble wrote:

Other users have noticed that the XML log does not include all transfers, and that it is particularly affected by initiating background transfers.

The XML log does not contain the background transfers and it never did.

cannot upload log files

I am prohibited from uploading a complete .log file from any session, these files contain sensitive information. I can tell you that the log file associated with the specific XML log file that I typed into the prior post is 1766 lines long, it contains multiple transfers, and ends with "sending special code 12" and then "sent EOF message". If there is something I should look for, I will do that. What is interesting is that it worked correctly for several years and just two months ago or so it stopped working correctly. Other users have noticed that the XML log does not include all transfers, and that it is particularly affected by initiating background transfers. The XML log file is exactly as I retyped it, and I could do that because it contained no sensitive information (actually, it contained no information at all).

I have requested that the WinSCP we are using be updated to the latest version, If this update is approved, I will update this thread.

Re: XML logging stopped working Version 5.9.4

So are you able to "post [attach] matching session and XML logs", as I've asked you for before?

tried to enter the requested info

I tried to type the requested info here, got a "please verify you are not a robot" promt but had no screen or way to respond, had to close session and try again.
I will ask if it is possible to upgrade, it may be very hard.
the regular logfile looks completely normal. The XML file contains only the session start info and a session end tag. I will try again to type that in

<?xml version="1.0" encoding="UTF-8"?>
<Session XMLNS="" name=bill.xxxxxxxx" start'"2.21-11-10T14:40:48:310Z">

The regular log file looks completely normal, it is 119 KB in size.

Re: XML logging stopped working Version 5.9.4

Can you reproduce the problem with the latest version of WinSCP? 5.9.4 is almost 4 years old.

Are the transfers logged in a regular session log? Can you post matching session and XML logs, where the transfers are recorded in the session log and omitted in the XML log?

update to XML logging anomaly

Other users who I prompted to check report other anomalies, such as the XML log not capturing all files transferred when background transfer is enabled, not sure yet what the extent of this is.

XML logging stopped working Version 5.9.4

I, and several other users, use WinSCP to move file across a private network. A couple of months ago (I just noticed this last week), the XML logging feature for me (but not for other users) stopped working. Instead of logging the file transfers, it logs the session open and nothing more. The regular logging is working fine. I looked back at the historical logs and the problem started on a day where the workstation I was using was moved, possibly interrupting a file transfer in process. Oddly, the same behavior happens if I run WinSCP on a different workstation (also on the same network) which I had not used before with WinSCP. There is no INI file in the directory specified in the settings, so it can't be that. Actual transferring of files works correctly.

Any suggestions for troubleshooting this issue? It would be very helpful if the XML logging would again work correctly.