Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Connection Failed since remote server changes

This does not seem to be related to a certificate.

Please attach a full session log files from both machines (using the latest version of WinSCP).

Connection Failed since remote server changes


This is a bit of a puzzle for me, I have a server that uses WinSCP to download files from a remote site on a daily basis, but have recently had Connection Failed messages. These seem to coincide with an upgrade taken place on the remote side, and the named host name has a new IP address and certificate behind it.

I thought this could be an issue on the remote side, however I tried connecting via my laptop instead and it worked. The difference being that I was prompted to accept the connection using the new certificate on my laptop.

I have tried setting up a new site by exporting the working one from my laptop using the IP address rather than host name, but it hasn't helped unfortunately. I believe the issue may be that it has cached the previous certificate details and is not prompting to save the details of the new one, however I am happy to listen to better ideas!

The details of the connection:
– Protocol: FTP
– Encryption: TLS/SSL Implicit
– Min TLS 1.0 , Max 1.2

Here's an extract from the log for further info:
. 2021-11-03 11:00:00.470 Connecting to XX.XXX.XXX.XX:990 ...
. 2021-11-03 11:00:00.470 TLS layer changed state from unconnected to connecting
. 2021-11-03 11:00:00.470 TLS layer changed state from connecting to connected
. 2021-11-03 11:00:00.470 Connected with XX.XXX.XXX.XX:990, negotiating TLS connection...
. 2021-11-03 11:00:15.437 Timeout detected. (control connection)
. 2021-11-03 11:00:15.437 Connection failed.
. 2021-11-03 11:00:15.437 Got reply 1004 to the command 1
* 2021-11-03 11:00:15.484 (EFatal) Connection failed.
* 2021-11-03 11:00:15.484 Timeout detected. (control connection)
* 2021-11-03 11:00:15.484 Connection failed.

Many thanks