Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: FTP through SSH tunnel not connecting

OK, you are trying to connect using SFTP protocol to FTP port 21. I assume that's mistake. Your server is FTP, right? Not SFTP.

WinSCP does not support tunneling FTP sessions.
But you can tunnel it through PuTTY, see:

Re: FTP through SSH tunnel not connecting

I did post the logs but removed it in case it contains any sensitive data I missed.

I meant SSH tunnel is authenticated just fine, then it opens FTP link to (as the /var/log/vsftpd.log logs shows) but then it never logs-in the FTP server, it just hangs there.

See re-attached log.

Re: FTP through SSH tunnel not connecting

Sorry, I do not understand what you mean by "WinSCP authenticate ok ... but it never logs in". Also it does not look like you have posted the log.

FTP through SSH tunnel not connecting

I've setup a new server and want to connect using WinSCP without having FTP access directly on the server, but through SSH and once on the server connect to FTP on port 21.

SSH tunnel appears to work fine, WinSCP authenticate ok, then connect to the FTP, but it never logs in and reports a timeout!?

Here are what I get in various logs:

==> /var/log/syslog <==
Jan 12 14:39:16 xxxxxxxxxx systemd[1]: session-61.scope: Succeeded.

Jan 12 14:40:52 xxxxxxxxxx systemd[1]: Started Session 62 of user xxxxx.

==> /var/log/vsftpd.log <==
Wed Jan 12 14:40:52 2022 [pid 92850] CONNECT: Client ""

Attached is full log for WinSCP.

I've spent a few hours on this and can't find what is wrong with the configuration.
At first WinSCP told me to disable "Optimize buffer size" (translated from French), which I did to no avail.

I tried disabling firewall entirely it didn't appear to help.

Any help would be very much appreciated.

EDIT: I finally dropped the SSH Tunnel configuration and it worked, however I wanted to use a different FTP user and cannot in this way :(