Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


"C:\Program Files (x86)\WinSCP\WinSCP.exe" scp://%hostname% /rawsettings shell=/bin/bash

Re: BASH error, scp from commandline

I couldn't find any clear explanation of what these switches are supposed to do. Thanks for your help, but I am giving up on WinSCP. I have found another application whose instructions are more clear to me, and which does what I need.

Re: BASH error, scp from commandline

And have you tried the /rawsettings switch as suggested in the article linked above?

Re: BASH error, scp from commandline

Thank you, I have read the documentation. I guess I should have mentioned that I have already tried every variation of /shell=/bin/bash that I can think of.

BASH error, scp from commandline

I am running WinSCP V 5.1.3 on a Windows 7 box.

I am trying to connect to a site which does not allow ftp. All I need to do is copy a single file from here to there. I am using this commandline: scp:// /upload filename

I get back this:
Searching for host...
Connecting to host...
Authenticating with pre-entered password.
Starting the session...
Connection has been unexpectedly closed. Server sent command exit status 1.
Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended).

Is there some way to set the BASH shell as a commandline option?