Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Synchronize subdirs fails

Thanks for the log. According to them, the downloads of the directories are terminated by the server (for SCP protocol the downloads are server-driven), like if there were no files in them. I have no idea why. Are you able to download directory manually, not by using synchronize function?

Re: Synchronize subdirs fails

Hi Martin,

Sorry for the delay, I've been out of office for some days.

I just tried the same again on my system, but now with debug level 2. I only did one iteration, so the result was the creation of 5 empty top-level directories.

You can find the log on <invalid hyperlink removed by admin> for the next 7 days.

You requested also an export of my settings. I didn't immediately see how to do that. I did verify the file transfer protocol and it is scp.


Re: Synchronize subdirs fails

I've tried it step by step, with both SFTP and SCP. No problem. The directories were synchronized after the first try. Can you export your configuration and send it to me? Or can you turn on logging and post it (or send it to me)? Thanks.

Re: Synchronize subdirs fails


I just did the following.
* Create an empty directory on the local machine (the one with WinSCP) and make that directory the current one.
* The remote machine (running Cygwin & sshd) contains a directory /cygdrive/c/users/jvnn/XYZ containing 5 subdirectories but no files. Each subdirectory has some subdirectories and/or files in it.
* I click "Commands | Synchronize". A window appears with the local and remote directories and the options.
* Checked options are "Both, Preview Changes, transfer type: binary". The only other available option is "existing files only" but I leave that one unchecked. All others are grayed out. The comparison criteria are grayed also, but "Modification time" is selected.
* I click "Ok". WinSCP starts calculating the directory size. In that process it seems to descend into the full hierarchy, although I'm not sure about it.
* It then shows the "Synchronization checklist". This list only contains the 5 toplevel directories, all checked.
* I click "Ok". WinSCP does some synchronization work.
* I end up with 5 newly created empty directories on my local machine.
* I follow the same procedure (starting with "Commands | Synchronize"). It now shows a synchronization list with all files and directories it finds on level one.
* This process has to be repeated till the full hierarchy is covered.

Is there a specific option to "recurse subdirs"? I do have the impression that it does recurse the subdirs, but it doesn't create their content anyway...


Re: Synchronize subdirs fails

I'm not able to reproduce the problem. Can you simple test with empty local directory and some folders on remote side? Also what synchronization options have you checked?

Re: Synchronize subdirs fails

I don't know whether it is relevant, but I am performing this sync in the following setup:

* Both ends run Windows XP Pro SP 2
* Server side runs Cygwin with sshd (recent version)
* Client side uses WinSCP 3.8.1 build 328
* Transfer protocol (I suppose scp, but didn't verify)

Synchronize subdirs fails

Version 3.8.1, build 328

Suppose that I have a three level deep directory hierarchy remotely and I want to synchronize it with a local directory.

I execute "Commands | Synchronize" and select "Both , Preview changes, transfer type binary".

It seems that on a first run, WinSCP synchronizes all files in the top level directory and it also creates the missing directories on top level.

On a next run (so again "commands | Synchronize" with the same settings) it doesn't detect any changes in toplevel anymore (that's ok), descends in the newly created directories and detects that some files and directories are missing there. It now syncs the files and adds any missing directories (again without filling these directories).

After four iterations, the full directory hierarchy will be synchronized.

It seems that WinSCP doesn't correctly synchronize the contents of a newly created directory. Is this a bug or do I overlook something?