Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Problem Solved

Hi again Martin,

I'm not sure what's going on with my mail client. It seems I have an email stuck in drafts since Friday afternoon that never made it to you because every time I hit "Send", Yahoo fails to send it. This is the email's body:
Good news! I think the problem is gone lol

So after my last email to you I remembered something else that happened recently (within the last few months) that could have been responsible for this bug... I had 2 thoughts:

1) I remembered that in the last few months, there has been 1 other thing that could also be responsible for this bug besides a WinSCP update and that is a Windows Update.

2) It felt a bit off that all drag and drop scenarios work except the one from Windows Explorer's window... I thought that could easily mean Windows is involved in this bug.

So I decided to run any currently queued up Windows Updates (I usually only let Windows update whenever it gives me no choice lol), you could say there's usually tops about 2 months of updates. So the machine restarted, I ran Windows Update a second time to confirm that all updates were accounted for, then ran the drag and drop test in WinSCP's portable version and there was no bug! I then ran it in my regular WinSCP and there was also no bug anymore! HURRAY!

That being said, I'm unsure what the culprit was after all. I guess even the simple restart could have been the solution after all (since I usually put my Windows to sleep every night instead of shutting it down). *crossed-fingers* it won't come back after I put it to sleep tonight (I will test for the bug again tomorrow to be sure).

Thank you for putting up with me through all of the back and forth emails. I'm glad to be rid of this problem!


PS: I can also gladly report that the problem did not recur after putting the PC to sleep and trying again!

Re: Drag & Drop stopped working when dragging from Windows Explorer to the server window

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Drag & Drop stopped working when dragging from Windows Explorer to the server window

Running Windows 10 and WinSCP v5.19.6.

For about a couple of months now (one of the recent updates) Drag & Drop has stopped working properly. To clarify, from the following 4 scenarios, only 1 of those 3 has stopped working:
1) Dragging a file from a Windows Explorer window to the remote window (server). BROKEN.
2) Dragging a file from WinSCP's local window to the remote window. WORKS.
3) Dragging a file from WinSCP's remote window to the local window. WORKS.
4) Dragging a file from WinSCP's remote window to a File Explorer window. WORKS.

Further details on the broken scenario:
In scenario 1 the file does get moved to the remote directory where it was dropped but the remote directory then just blanks out (i.e. there's all of a sudden no folders or files visible). This glitch also blanks out all other currently open remote directories. The only solution that I've found once this happens is to close and re-open WinSCP.

Scenario 1 used to work prior to one of the recent updates that broke it sometime this year.

As a workaround in the meantime, I've been using scenario 2 to move files between local and remote sessions but every now and then I forget and end up doing scenario 1... the annoying part about that is I have to close and re-open all my previously opened files from the remote session after closing and re-opening WinSCP which makes me lose valuable time and progress.