Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks. I've updated the documentation accordingly.

Re: Terminal integration not working with wsl-ssh-pageant

Thanks for the input.

Hm, my mentioned command and the commands listed under are working now.
I guess the PC reboot fixed it.

Btw, the ssh.exe command opens it in the Windows terminal for me too. So "Win32-OpenSSH" and "Win32-OpenSSH in Windows Terminal" seem to be doing the same in Windows 11.

Re: Terminal integration not working with wsl-ssh-pageant

Just as a wild guess: WinSCP is 32-bit application, so it runs 32-bit version of cmd. What may cause some differences. Can you try running 64-bit version of cmd by using %SYSTEMROOT%\sysnative\cmd.exe?

Btw, did you consider using native Windows OpenSSH instead of WSL?
See also PuTTY commit 8a288393.

Terminal integration not working with wsl-ssh-pageant


I have set up wsl-ssh-pageant ( which works when I run an ssh command in the terminal, but I'm getting permission denied (publickey), if I try to use the same command via WinSCP.

What could be causing the issue?

This is the command which works when running it in the terminal but not when configured in WinSCP:
cmd.exe /c start "" "%LOCALAPPDATA%\Microsoft\WindowsApps\wt.exe" ssh !U@!@ -p !#