Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Your question solved the problem.
Actually, since it was a new VSCode installation, I didn't even try to open a 1st local file before testing from WinSCP.
So I've just tried, locally, and the classic 1st time window was displayed, something around
Are you sure you want to open a file from this source blablabla blablabla

It was this step which was blocking via WinSCP (the window not showing up)

Now it's working fine again from WinSCP.

Thanks for your help !

And can you even open a local file from VSCode commandline?

The "The file xxx is already opened in the editor or is currently opening" message comes from VSCode, right? (not from WinSCP)

It's working well with SublimeText

Yeah, I've just tried to click Edit manually just in case.

That's weird, must come from my Windows.

Thanks anyway.

With the same settings, VSCode is working for me. Are you sure you "Edit", not "Open"?


Thanks for your reply.
I've joined 2 screenshots.
The path in WinSCP is good since VSCode launches when I want to open a file.
I took a screenshot of VSCode but there is nothing special (it tries to load something during 4-5sec, I can see it on the pointer).

Can't edit a file via FTP with VSCode

Hi there,

I'm using WinSCP 5.21.3 on Windows 10. I'm connecting to a FTP.
I've added VSCode as external editor in the settings, when I try to open a php or html file, VSCode is opening, he tries to load something, but the file is not opening then, nothing happening.
When I try to open a 2nd the same file, I have a message saying "The file xxx is already opened in the editor or is currently opening".

I've tried to install user and system verions of VSCode, I meet the same issue.

Thanks in advance.