Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Here are the commands I could find. I don't think any of them do that.
Usage: SubtitleEdit /convert <pattern> <name-of-format-without-spaces> [<optional-parameters>]

    one or more file name patterns separated by commas
    relative patterns are relative to /inputfolder if specified
    /fps:<frame rate>
    /targetfps:<frame rate>
    /encoding:<encoding name>
    /pac-codepage:<code page>
    /track-number:<comma separated track number list>
    /inputfolder:<folder name>
    /outputfolder:<folder name>
    /multiplereplace:<comma separated file name list> ('.' represents the default replace rules)
    /multiplereplace (equivalent to /multiplereplace:.)
    /ebuheaderfile:<file name>
    /ocrengine:<ocr engine> ("tesseract"/"nOCR")
    /renumber:<starting number>
  The following operations are applied in command line order
  from left to right, and can be specified multiple times.

Example: SubtitleEdit /convert *.srt sami
Show this usage message: SubtitleEdit /help
List available formats: SubtitleEdit /help formats

Regardless, I've since solved the problem by creating a second but private share that points to the same location. So I can still have the read only one for guest access, but the other requires credentials. Didn't know I could do that before.

Does SubtitleEdit have a command-line parameter, which you/WinSCP could use to point it to a video file in a different folder (SMB) than where the subtitle file is (temp)?

It's a read-only share. But I can get write access using SSH (SCP/WinSCP). I guess I was just hoping there was some way to make SubtitleEdit automatically recognize the video file that it is in the same folder as the subtitle file I open in SubtitleEdit (through WinSCP) to get WinSCP to tell SubtitleEdit, hey there are these other files in the folder too (instead of just the file by itself in a temp folder).

Re: Double click subtitle

@wokid59837: I do not understand what you need WinSCP for in your setup. Why don't you open the subtitle file in SubtitleEdit directly from the SMB share?

Double click subtitle

When I double click and open a subtitle file in WinSCP (using SCP) I'd like to be able to have it automatically see the video file located in an SMB share. At the moment WinSCP copies the subtitle into a temp folder and then the file opens in SubtitleEdit and I have to go manually find the file (in the SMB share) and open the video file from within SubtitleEdit and then it works fine (without having to copy the entire file).

Just to be clear both files are on a read-only SMB share. But I access the subtitle through WinSCP (using SCP) (so I can edit and save it), once it is open in SubtitleEdit I use its interface to open the file on the SMB. So I guess what I would like is some preference to tell WinSCP where the share is so it can make a symbolic link in the same temp folder that points to the same location on the SMB share. Then SubtitleEdit would be able to see the video file immediately. So I guess this would be a per site preference called corresponding read-only SMB share or something.

Re: Changing the default double-click behavior?

It's hard to help, as you didn't show us your editor configuration. Please post some screenshots.

Without more information, I can only guess that you have catch-all (*.*) text-editor above your image editor.

Alternatively, as you consider the "Edit" functionality useless, don't use it! Use "Open" instead. You can configure WinSCP to "Open" on double-click:

Changing the default double-click behavior?

When I double click on an image in WinSCP, it opens it in a text editor. This is useless behavior, and I'd rather it just open the image in my default image viewer.

I don't understand how the editor preferences work. I set .png and .jpg files to be opened by my image viewer, but it still opens them with the built-in text editor.