Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks for your response, Martin!

I tried pressing Ctrl+Shift, but nothing changed; PuTTY didn't open. Nevertheless, when I regularly open putty from WinSCP and I read all the messages (first time I really see it), I see, that the key format is too new. I also read how to fix that by converting the private key in PuTTYgen.

Sorry for my blindness! And thanks again for your help.

Re: PuTTY does not use Private key

Hold down Ctrl+Shift while clicking the "Open in PuTTY". WinSCP will put PuTTY commandline into clipboard. What's it like?

PuTTY does not use Private key

Hi guys,

great job! I configured some WinSCP settings which use my private key to connect to my "servers" (mainly Raspberry Pi). The problem is, as soon as I open PuTTY from WinCP, PuTTY asks me for a password, whereas WinSCP doesn't.

I read multiple topics here in the forum without solution or with solution I didn't understand. I remember one answer was, that the session config of WinSCP and PuTTY differ, but I don't know how to fix that. Especially since I don't have any separate PuTTY server configs on my laptop, but e.g. I can connect with a key and no password to our business' servers but with the same WinSCP it doesn't work for my private "servers".

Would be great if you could help me.

Thanks and kind regards!