Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review

Dan Zeman

Re: Directory profiles do not work well with remote symlinks

Thanks! It helped. (Once I figured out I also should go to the menu and erase the cache :-))
Dan Zeman

Directory profiles do not work well with remote symlinks

I have a number of directory profiles where the remote path contains a symlink. I prefer to use these paths because they are more stable. The underlying real paths occasionally change when the admin reorganizes the remote network. Unfortunately, WinSCP seems to remember the underlying physical path, even though I entered the symlink path in the directory profile.

For example, in one profile I have:

which used to translate to the actual path

The remote network has changed and now the underlying path is
(without "spec/")
The symlink
... still works on the network.
However, the directory profile seems to remember the old underlying address (although I never entered it in the profile!) and, not surprisingly, shows an error message that the path does not exist. I tried entering the remote path in the profile anew, but to no avail, it stubbornly insists on the old path. The only way I succeeded was to start at the top directory, gradually descend the hierarchy by clicking on directories, and once in the desired directory, saving it as a new profile with a new name.

Is there a way to tell WinSCP that it should not remember the underlying physical paths? I was looking for such a setting in the Options but did not find anything.