Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Would you be able to (g)zip a test file before and after the type changes and attach them here for us to check?

I'm working with WinSCP 5.19.5 installed on Windows Server 2019 build 17763 and with WinSCP 5.21.5 installed on Windows 7 SP1 and Windows 10, all of this installations works with Oracle Linux 9.1.

We are working with SFTP protocol (ver 3) on port 22 (tried now with SCP protocol with port 22, same result), tried switching on/off "Force text transfer mode...", tried switching on/off "Remove BOM and EOF marks" in file transfer settings and no luck.
I see the change when I check with file command the file type before and after editing + after editing (and changing file type), our executable which need ini file for parameters does not works, recovering ini file with correct format from backup makes our executable works ok.

Re: File type changes after editing

What protocol is this about? Where do you see the type change?

File type changes after editing

When I edit an ini file (tried Notepad++/Ultra Edit/Notepad/builtin WinSCP editor) under WinSCP, its type changes from INItialization configuration file to Non-ISO extended-ASCII text. How can I edit an ini file and preserve its type under WinSCP?

Thanks in advance for any help.