Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: Cant upload/overwrite "hidden" file with WinSCP to QNAP via WebDAV

Did you try unlocking the file?
Though I do not really expect this to help, but it's worth trying.

Do you have any other other kind of access to the remote files (except WebDAV)?
In general, this is not really WinSCP question, so we cannot help much here.

Regarding the "423 Locked" error: This is how WebDAV works. You basically have to upload whole file, before the server gives you any kind of feedback (even if the upload it not possible at all).

Cant upload/overwrite "hidden" file with WinSCP to QNAP via WebDAV

I was about to upload a 4gb big file to a QNAP server via WebDAV in Windows 11 Explorer. The copy process seemed to work but then after a few minutes, the copy process just stopped with an error. I now had a 0kb file in the webdav folder. I tried to delete the file via Windows Explorer, didn't work. I then deleted the file on the QNAP NAS itself.

I tried to copy the same file then again in Windows Explorer, but Windows claimed there was a file already with the same name, where it showed an empty folder. I deleted the entire folder, recreated it, tried to copy. Still didn't work, claiming file exists. Overwriting also didn't work.

I then tried to connect via WinSCP. WinSCP also showed an empty folder. I began to copy the file. It copied for 10 minutes to 100% but then at 100% it gave the error "423 Locked".

What's going on? How can this be resolved? And also why does WinSCP copy the file to 100% but then just says it couldn't be copied at the end? Wouldn't it be wise to do it the other way around?

Using latest WinSCP version.