Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: NU1108 error when installing NuGet package in my VS project

Do you have the problem with any VS 2019 project (even basic .NET console app)? Or just with Azure projects? Please give us step-by-step instructions for reproducing the problem.

.NET 6 should not be a problem.

Hi again,

I managed to get my Azure func. to work in cloud as well.
Had wrong target framework.

Once I changed to .NET Core 2.1. (had .NET 6.0)
Found the correct dll to reference.
Added a whole lot of other missing dependencies.
It publishes and works as expected.

But still not able to install the NuGet package.
Same error (NU1108).
I'm pretty sure I did install it a couple of weeks ago, (VS2019)

// Alexander

NU1108 error when installing NuGet package in my VS project

I get an NU1108 - Cycle Detected error, when trying to install the NuGet package in my VS project.
This is no matter which of the 6-versions I try.
(haven't tried any of the 5-versions)

I have tried to install WinSCP, and reference it manually.
Works fine locally.
But after deployment to Azure Func, I get an error abt. missing assembly System.Threading.AccessControl.
I see from other posts, that I need to reference "the .NET standard build".
But I see only 1 dll in my program-folder, and that is the one I reference.

Hope you can help me out here.
// Alexander