Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Since I ran across exactly this problem, and this thread was high on Google, I'll post my particular solution here.

Logging in via a normal shell caused an error message that said the normal (non-root) user could not navigate to their home directory. This was caused by the /home permissions being 700, since I had meant to 'trap' users in their home directory and symlinks I had put in there. Unfortunately, this appeared to backfire, not allowing them to log in at all!

I changed the permissions of /home back to 755, and the problem was solved. Try and see if your /home directory has incorrect permission if you have this problem!

Re: solution of sorts

Hi All,
i've faced the same problem today, non from fixes found on the internet could help me, then I found that my /usr/sbin/sshd longs to see some libraries (but they're missing).

1. Previously running ldd /usr/sbin/sshd was showing me only:

ntdll.dll => /cygdrive/c/WINDOWS/system32/ntdll.dll (0x7c800000)
kernel32.dll => /cygdrive/c/WINDOWS/system32/kernel32.dll (0x77e40000)
and some errors here

2. Now it's showing the correct full list and no errors:
ntdll.dll => /cygdrive/c/WINDOWS/system32/ntdll.dll (0x7c800000)
kernel32.dll => /cygdrive/c/WINDOWS/system32/kernel32.dll (0x77e40000)
cygcrypt-0.dll => /usr/bin/cygcrypt-0.dll (0x10000000)
cygwin1.dll => /usr/bin/cygwin1.dll (0x61000000)
ADVAPI32.DLL => /cygdrive/c/WINDOWS/system32/ADVAPI32.DLL (0x7d1e0000)
RPCRT4.dll => /cygdrive/c/WINDOWS/system32/RPCRT4.dll (0x77c50000)
Secur32.dll => /cygdrive/c/WINDOWS/system32/Secur32.dll (0x76f50000)
cygcrypto-0.9.8.dll => /usr/bin/cygcrypto-0.9.8.dll (0x6ba40000)
cyggcc_s-1.dll => /usr/bin/cyggcc_s-1.dll (0x67f00000)
cygwrap-0.dll => /usr/bin/cygwrap-0.dll (0x67300000)
cygz.dll => /usr/bin/cygz.dll (0x692c0000)
cygssp-0.dll => /usr/bin/cygssp-0.dll (0x67280000)

I've installed crypt cygwin package.
Hope this will help you even posted a year

solution of sorts

I just hit the same issue. Short Answer: try copying all DLL files from cygwin\bin into cygwin\usr\sbin

Long Answer: What helped me figure it out was to "run as..." sftp-server.exe on the console with the user while not in local admin group. That action yielded an informational event in the Windows System event log:

Application popup: sftp-server.exe - Unable To Locate Component : This application has failed to start because cygwin1.dll was not found. Re-installing the application may fix this problem.

Changing the path didn't help even after net stop/start sshd so I then copied the DLLs from cygwin/bin into usr/sbin and from there, magic happened, no more escalated privileges to workaround.

Very frustrating how long it took to isolate this, oh well... hope this post 2.5 years after the question, helps someone.

Re: Same problem

carloseduardoab wrote:


I have the same problem. Were you able to figure this one out?

Sorry, I was never able to get this resolved under the described environment.

However, I did upgrade to Enterprise Ed R2 and the problem did not return. Please note that ALL permissions were set to default after upgrade.

I am currently testing with FreeSSHD as a replacement to cygwin. FreeSSHD appears to have a more user friendly GUI for services such as privilege separation and share isolation.

Same problem


I have the same problem. Were you able to figure this one out?

Re: Server sent command exit status 128

martin wrote:

Have you checked a log of the OpenSSH server?

Thanks for the prompt response,

I have determined that the issue is indeed server side and is probably some type of credential / policy problem. I determined this via the STFP command using a limited user account and was disconnected immediately after authentication. I just submitted my notes on Cygwin's site regarding this issue.

Re: Server sent command exit status 128

Have you checked a log of the OpenSSH server?

Server sent command exit status 128