Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Finally I used PowerShell to achieve what I want and works better.

Re: timeout setting not working

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Timeout setting not working

Hi all,

I run the following commands to upload files to many SFTP servers but the /timeout=5 option is not working and the session just get stuck when one server is not available. any help is appreciated.
"C:\Program Files (x86)\WinSCP\" /ini=nul /script=C:\test\script1.txt sftp://tester:password@  /timeout=5 /hostkey=* 
"C:\Program Files (x86)\WinSCP\" /ini=nul /script=C:\test\script1.txt sftp://tester:password@  /timeout=5  /hostkey=*
"C:\Program Files (x86)\WinSCP\" /ini=nul /script=C:\test\script2.txt sftp://tester:password@  /timeout=5  /hostkey=*

Pantelis komatas