Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: TLS over FTP Passive Issue

It can be possibly caused by this issue. What do you think?

TLS over FTP Passive Issue

First the facts:
Winscp ver 4.2.1(build 428)
Windows Vista 64bit
FTP with TLS explicit encryption
Using GUI

The short error message:
Timeout detected.
Could not retrieve directory listing
Entering Passive Mode (192,168,83,20,17,132)
Error listing directory '/'.

The log:
<invalid hyperlink removed by admin>

My story:
I am connecting to a remote ftp server and was connecting but the server was refusing to list the directory. It looked like it was an issue with my router being that it refused to communicate with my local IP and would only connect to my WAN IP. So I switched it over to passive mode and still failed to connect. The ftp server is running passive mode on ports 4500-4600. After scratching my head for nearly 2 hours I decided to give in to my friend's demands that I try filezilla. So I tried it (knowing full well there would be no difference) and it worked. I cannot tell you how furious I was. I promptly uninstalled Filezilla for its impudence.

But what could be causing this?