Post a reply :: Support Forum

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Tip: Styles can be applied quickly to selected text.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

Henrik

Thanks Martin.

Everything works very well now (and no more timeouts).

Not only that, but if there's a file I want to edit outside the managed area, I can open a second copy of WinSCP and do it there, using the External editor service.

All good.

Nice software!

All the best,

- Henrik
martin

Henrik wrote:

Have I got this right?

Yes.

Except that the changing of timeouts will hardly help with disconnects.
Henrik

Well, I've been poking around and doing some lateral thinking on this issue, and have come up with a solution, but thought I'd get a reality check here.

1. Make backup of remote files <grin>

2. Copy remote directory structure to local computer.

3. Load local copies into editor (Notepad++ in my case)

4. Set Commands/Keep Remote Directory Up to date on

(and to keep session open - this has been a problem - I've experimantally set server timeout to a value a bit greater than keepalive timeout).

Everybody happy...

Have I got this right?

- Henrik
Henrik

Restore session including files being edited with ext. ed.?

I use Notepad++ for my PHP editor and WinSCP for FTP connection (Notepad++'s FTP_Synchronize add-in is flaky).

Works great, but if I go away for a while, come back, and find the session has been ended, then I have to re-create my editing session (including restoration of file changes not yet saved - admittedly rare).

As a workaround attempt, I've set a custom edit directory, and *unchecked* cleanup obsolete directory...

But when I close WinSCP all local text files are deleted.

So I presume there's something I'm not understanding.

How do I get WinSCP to leave local copies of files being edited alone?

Thanks,

- Henrik