Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: SFTP server command line must be shorter than 50 characters

Thanks for your post. This issue has been added to tracker.
Frank Gruellich

SFTP server command line must be shorter than 50 characters


this is my first post and bug report. Please be nice...

I'm using WinSCP 4.2.3 (Build 494) in Commander Style. I'm following the F.A.Q. how to use WinSCP with sudo. The OS running the SSH server is a standard CentOS 5.2 and its SFTP server is located in "/usr/libexec/openssh/sftp-server". The remote user I'm supposed to use is "someotheruser". So I'm trying to write
sudo -u someotheruser /usr/libexec/openssh/sftp-server
in Environment -> SFTP -> Protocol options -> SFTP server. Unfortunately, the input box accepts only up to 50 characters, so the input is truncated after ".../sftp-se". Of course, this does not work. If I create a shorter SFTP server path by symlinking /usr/bin/sftp-server -> /usr/libexec/openssh/sftp-server and use
sudo -u someotheruser /usr/bin/sftp-server
it works. If the username is shorter (eg. someuser) it works, too. However, both are not an option. Also usage without sudo is not possible, as it would break our audit trail. Is this a bug or (undocumented?) feature?

Thanks in advance.

Kind regards,