Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: [4.2.8] Broken 'Keep remote directory up to date' function

This bug has been added to tracker.


Regged here now. 8)



Well, it beats me, that's for sure. :shock:

I assume you are reffering to a setting under:
- Adjust remote timestamp to local conventions
- Adjust remote timestamp with DST
x Preserve remote timestamp (this one is grayed out for me)

It makes no difference which setting I choose, WinSCP v4.2.8. always transfers all of the files, again and again and again.

My server is adjusting it's time via NTP so all of my files on the server have correct timestamps, always showing exact time as my local computer's clock. Although I've noticed, when I look at the files inside the server (with SSH) their time is correct, but when I look at the listing in WinSCP v4.2.8 the MTime is skewed by one hour.

For example, I go into the server and change a file. I do this exactly at 11:18, my local computer clock shows 11:18, AND my server's clock shows 11:18. After doing 'ls -l', MTime of that file shows 11:18. When I look at that file in WinSCP v4.2.8 it shows MTime 10:18, and when I look at it with WinSCP v4.2.7 it shows MTime 12:18.

Now, I'm puzzled :roll: I don't know why v4.2.7 works correctly for me, and why I can't make v4.2.8 to work correctly for me.

Please advise.

Thank you very much.


Re: further info

In 4.2.8 WinSCP changed its timestamp calculations on Windows 7 to catch up with changes Microsoft has introduced in Windows 7 (see tracker). So I believe that it worked for you in 4.2.7 by pure luck. And I hope it is just matter of configuring WinSCP correctly to make it work on 4.2.8.

Please read FAQ. If that does not help, come back.

further info

Hello Martin,

I'm happy to assist in debugging in any way I can.
Just let me know if you need any further info or bug reproduce/logs, etc.

Session protocol = SSH-2
SSH implementation = OpenSSH_4.3
Encryption algorithm = aes
Compression = No
File transfer protocol = SFTP-3
Can change permissions = Yes
Can change owner/group = Yes
Can execute arbitrary command = No
Can create symlink/hardlink = Yes/No
Can lookup user groups = No
Can duplicate remote files = No
Can check available space = No
Can calculate file checksum = No
Native text (ASCII) mode transfers = No
Additional information
The server does not support any SFTP extension.


OS Name Microsoft Windows 7 Ultimate
Version 6.1.7600 Build 7600
System Type x64-based PC
Processor Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz, 2001 Mhz, 2 Core(s), 2 Logical Processor(s)
Locale United States
Hardware Abstraction Layer Version = "6.1.7600.16385"
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 4.00 GB


Re: [4.2.8] Broken 'Keep remote directory up to date' function

What protocol are you using? What is your version of Windows?

[4.2.8] Broken 'Keep remote directory up to date' function

[4.2.8] Broken 'Keep remote directory up to date' function

This function worked perfectly since I started using it several versions ago. It sits and waits for changed files then transfers only those changed files.

Now, in v4.2.8 this function is broken in the way that WinSCP always transfers all of the files (not just the changed ones) which slows it down dramaticaly. In a way, unusable.

Had to revert to v4.2.7 - works perfectly.

Keep up the fantastic work! :D