Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Ah, so I'm not the only one who didn't see anything suspicious in the log. :)

Ok, thanks anyway - I'll try to check it from the server side, and maybe will make another attempt without Linksys router (somehow I suspect it's causing this trouble)...

Re: Multiple files over FTP: Lost Connection. Timeout detected.

Sorry, there's nothing in the log indicating why the connection is being terminated. You may try to inspect the server's log file.

Multiple files over FTP: Lost Connection. Timeout detected.


When I work with a large number of files (copy, delete) on a remote FTP server, WinSCP stops with an error "Lost Connection. Timeout detected." after some time. Fewer files are always copied correctly, no matter what size they are. But if I copy something like all folders of a phpbb installation at once, it seem to fail. WinSCP processes some files, and then it gives this error. I tried other client (CuteFTP) - its behavior was slightly different, but I still got an error stating there's no connection to the server in the middle of copying the files.

The complete WinSCP log is located here: <invalid hyperlink removed by admin>

I thought the issue is related to the FTP server itself. So I asked my friend to do the same operation (copy / delete the same set of files to the same server) from his location (he uses a different ISP) - and it worked fine for him, without any issues.

I don't think it's my ISP that is causing this. I tend to blame my system, or my home router (LinkSys RV-042). But I can't figure out what's exactly wrong with my setup. Could you please help me to track this issue and find a work around?


Using Passive mode doesn't change the situation. I get some (many) files copied, and then the following error appears:

> 2010-12-05 12:46:40.124 PASV
< 2010-12-05 12:46:40.124 227 Entering Passive Mode (93,95,102,190,227,24)
> 2010-12-05 12:46:40.124 STOR message_config.png
. 2010-12-05 12:47:01.108 Transfer channel can't be opened. Reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
. 2010-12-05 12:47:01.108 Copying files to remote side failed.