Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Re: [newbie] "Nothing to synchronize"?

Both of you, does synchronization works for you correctly in the GUI?

I don't know. You could run the commands manually in the console to see if WinSCP reports errors.

if i delete all the files and if i run the script again also its not working for me..
i am not finding any files in the folder..its being empty..

I don't know why WinSCP was re-uploading the exact four files while leaving the other files, but I found a solution: FTP #2 already had some files in there: Simply removing all the files and relaunching the WinSCP script solved the issue. Maybe it'll work for you too.

it is not getting synchronized

I am also getting the same problem...
My Script is

open s
cd /usr/CSVs
synchronize local "C:\use"

I am getting output as
Local 'C:\use' <= Remote '/usr/CSVs'
But after this when i go and check my C:\use i am not finding any new files i means its not getting synchronized :( .
Please give me reply ASAP Thanks in advance

I notice, however, that 4 files are being uploaded from the local host to the second, remote FTP server every time I run the script.

I looks like it could be due to case (upper- or lower-case), since Windows doesn't make a difference between MYFILE.EXE and myfile.exe.

Does someone know more about this issue?

Thank you.

Found what it was: The remote FTP server is in a co-lo and requires cd'ing to the directory before attempting to download files:


option transfer binary
cd files
synchronize local c:\remote.ftp .


[newbie] "Nothing to synchronize"?


I just downloaded WinSCP 4.2.9 and tried to write my first script to synchronize a remote FTP server with a local XP host, before syncing this XP host with a second, remote FTP server.

Using the console, I can successfully log on, but "synchronize local c:\remote.ftp /files" does nothing and just displays "Nothing to synchronize."

Just in case, I...
1. Checked that there is a "/files" directory on the FTP server, and it's full of files
2. On the local host, I created a c:\remote.ftp, in case WinSCP couldn't create the directory itself.

Here's my script:
option batch on

option confirm off

option transfer binary
#remote server is reference
synchronize local c:\remote.ftp /files


Am I missing something obvious?

Any help appreciated, thank you.