Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


wow, that makes total sense. I was remoted into the server with my ID, but run the scheduled job as the administrator account. Switched to ini file config (easier than doing the registry stuff). Wish i could've found this page earlier.

Re: New version of WINSCP won't run as windows scheduled task?!!

Add /log=path_to_log_file switch and inspect the log file. Or post it here.

Also read:

New version of WINSCP won't run as windows scheduled task?!!

I have been running v 4.06 for a long time now and have several automated tasks that connect to sftp servers and do "gets" daily. One new client I need to connect to needs me to do a put each day, but their sftp server didn't like the timestamp being updated, so i had to get the new version to do the -nopreservetime option on the put command. So my batch file is just:
winscp.exe /script=<filename.txt> This is how i've done it for years-- except it was winscp406.exe before. I cannot get this batch file to run as a scheduled task-- keeps coming back with 0x1 status. I've checked permissions and who it's running as...etc. I even tried updating one of my existing clients that i do the daily gets for, and if i run the winscp.exe instead of winscp406.exe in my batch file, it doesn't work.

If i just manually run the batch file, it runs just fine....just not as a scheduled task.

Any ideas?