Post a reply

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


:oops: MEGA EMBARRASSED !! Can't spell. The file name was sitting as wnscptest.txt (without the 'i')!!

However some help regarding the non-saving of the password would still help.



'Cannot open file' err msg when rung from command line

I have the following simple script:

option batch abort
option confirm off
open pdgtt
put readme /home/purvez

This is saved in a file called winscptest.txt and is sitting in the same directory where winscp.exe is saved. When I run the following command line from that directory I get an error message saying: 'Cannot open file winscptest.txt' /script=winscptest.txt

I have also tried the following command but the same effect: /script=.\winscptest.txt

I'm running winSCP ver 4.3.6 on windows xp.

Anybody got any ideas of what could be the problem here?

I can run winscp.exe with a stored_session name from the command line and that works although I have to manually enter a password. Seems like the stored session does not retain the password.

Thanks in advance for all help/advice.