Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Copy fails with accented characters

Anonymous wrote:

Does that mean I am stuck here? Do you recommend any other way to manage a situation like this?

I cannot think of any workaround.
Guest

Re: Copy fails with accented characters

martin wrote:

OK, so you are duplicating a file on the remote side. This is not supported by SFTP. So WinSCP falls back to SCP for that operation. But I suppose a real copy operation (download/upload) works correctly, right?


Yes, it does operate correctly. Thank you.
Guest

Re: Copy fails with accented characters

martin wrote:

OK, so you are duplicating a file on the remote side. This is not supported by SFTP. So WinSCP falls back to SCP for that operation. But I suppose a real copy operation (download/upload) works correctly, right?


Thank you for enlightening me about that. Does that mean I am stuck here? Do you recommend any other way to manage a situation like this? I need to manage Linux servers from a remote Windows client. Using only Putty is just too much hassle in many cases, so I would like to have a graphical interface to do this. Thank you.
martin

Re: Copy fails with accented characters

OK, so you are duplicating a file on the remote side. This is not supported by SFTP. So WinSCP falls back to SCP for that operation. But I suppose a real copy operation (download/upload) works correctly, right?
Guest

Re: Copy fails with accented characters

martin

Re: Copy fails with accented characters

Please post a complete log file.
Guest

Re: Copy fails with accented characters

martin

Re: Copy fails with accented characters

Anonymous wrote:

OK, the documentation says that UTF-8 is NOT supported under SCP. Are the copy operations always done with SCP even when the selected protocol for the connection is SFTP?

No. But you may and up using SCP instead of SFTP, if SFTP is not available and fall back is enabled. Post a log file if unsure.

And no, it si not related to the internal editor.
Guest

Re: Copy fails with accented characters

[quote="Anonymous"]

Anonymous wrote:

martin wrote:

Try 5.0.5 beta.

I just noticed that when the SCP protocol is used instead of SFTP, the option "UTF-8 encoding for filenames", under "Environment", is greyed out. When connected, the accented characters in filenames are mangled. Doesn't SCP support UTF-8? Is this related to the problem with the internal editor?


OK, the documentation says that UTF-8 is NOT supported under SCP. Are the copy operations always done with SCP even when the selected protocol for the connection is SFTP? Should this be so or was it an oversight? This is a serious handicap. My servers do have a lot of directory and file names containing accented characters and this prevents bulk copy operations. I have to do them on the command line with Putty. By the way, why doesn't this happen with Putty?
Guest

Re: Copy fails with accented characters

Anonymous wrote:

martin wrote:

Try 5.0.5 beta.


I just did. The problem is still there.

Maybe this is related to the problem with the internal file editor reported here:

https://winscp.net/forum/viewtopic.php?p=38761#38761


I just noticed that when the SCP protocol is used instead of SFTP, the option "UTF-8 encoding for filenames", under "Environment", is greyed out. When connected, the accented characters in filenames are mangled. Doesn't SCP support UTF-8? Is this related to the problem with the internal editor?
Guest

Re: Copy fails with accented characters

martin wrote:

Try 5.0.5 beta.


I just did. The problem is still there.

Maybe this is related to the problem with the internal file editor reported here:

https://winscp.net/forum/viewtopic.php?p=38761#38761
martin

Re: Copy fails with accented characters

Try 5.0.5 beta.
Medalha

Copy fails with accented characters

I am using WinSCP 4.3.6 to help me administer a CentOS Linux server from a remote Windows machine.

When I try to copy directories or files containing accented characters, the copy fails. The following are resulting messages from WinSCP:


Command 'cd "/data/Jornal/Arquivo/Edies DA/Ano 2012"'
failed with return code 1 and error message
/bin/bash: line 6: cd: /data/Jornal/Arquivo/Edies DA/Ano 2012: No such file or directory.

Command 'cp -p -r -f "1553" "/data/Jornal/1553"'
failed with return code 1 and error message
cp: cannot stat `1553': No such file or directory.


However, when I move the same directories the operation is successful.
I always had this problem with WinSCP and I am using it since version 4.25 at least.
I don't have this problem when using Putty.
WinSCP is configured to use UTF-8.

Any information about this problem (or a correction if a bug exists) would be very welcome.

Thank you for this very nice piece of software.