Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Thanks - Find a solution

Thanks for your investigation.
This issue has been added to the tracker:
https://winscp.net/tracker/842
Sharon

Thanks - Find a solution

There is a flag on the external editor configuration window
"Force text transfer for external editors"
Once I removed it - the encoding remains.
I think that by default it should be false

Thank you for your help!
martin

Re: Lost encoding whan savin file

Possible explanation is that WinSCP saves the file to a different temporary folder on every edit. So Notepad++ does not consider it to be the same file.
Though that should not be the case during a single WinSCP run, unless you have checked External editor opens each file in separate window (process) in editor preferences. Can you check please?
https://winscp.net/eng/docs/ui_editor_preferences
Let me know!
Sharon

Lost encoding whan savin file

Hi,
Thank you for a great tool!
Version: 4.3.5 build 1463
Running on XP Pro
The scenario is like this:
I connect to remote Linux box (CentOS release 5.6 64Bit) using SFTP port 22
Double click to open text file on the remote box (file open using Notepad++)
Change the file encoding to UTF-8 (In Notepad++ -> Encoding -> UTF-8)
Save the file - > WINSCP copy the file to the remote box in the background.
Close Notepad++
Double click the file again on WINSCP
Notepad opens -> the encoding is not saved

I found out that if i first save the file on my desktop - then change encoding and drag and drop the file into WINSCP using binary file transfer - encoding will stay
So I tried the first steps using the default binary option (the combo on WINSCP toolbar) but it didnt help
Is this a bug or i am missing something?
Thank you very much!