Post a reply

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: WinSCP.SessionRemoteException: System Error. Code: 123. The filename, directory name, or volume lab

kiran wrote:

I could able to transmit the file with console application with same code.
but when we are trying to integrate with window service, we are getting the below error, while executing the service.

"WinSCP.SessionRemoteException: System Error. Code: 123.
The filename, directory name, or volume label syntax is incorrect"

Please try to help me to get resolve this issue.

Please, start a new thread and attach a full session log file showing the problem (using the latest version of WinSCP).

To generate log file, set Session.SessionLogPath. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.
kiran

WinSCP.SessionRemoteException: System Error. Code: 123. The filename, directory name, or volume lab

martin wrote:

Please post a screenshot.


I could able to transmit the file with console application with same code.
but when we are trying to integrate with window service, we are getting the below error, while executing the service.

"WinSCP.SessionRemoteException: System Error. Code: 123.
The filename, directory name, or volume label syntax is incorrect"

Please try to help me to get resolve this issue.

Thanks In Advance,
kiran
IGGt

Re: setting timeout problem

I have figured it now.

I needed to change:
open username:password@address -timeout=100 -passive=on

to

open ftp://username:password@address -timeout=100 -passive=on

and now it works,


cheers.
martin

Re: setting timeout problem

Please post a screenshot.
IGGt

setting timeout problem

I am trying to manually set the timeout in my script, but can't get it to work.

if I type:
winscp>open username:password@address -timeout=100 -passive=on

then it connects fine, and the timeout is 100 seconds.


But If I try to put this into my script file it fails:
c:\>winscp.com /script="path/to/script.txt"

script.txt:
open username:password@address -timeout=100 -passive=on
command1
command2

Then I get the following error: "The filename, directory name, or volume label syntax is incorrect"

I tried adding it after the /script parameter as /timeout=15 or -timeout=15, but get the same error.

Is there something I am doing wrong?