Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Because they are available for a limited time. No downloads per day means removal and this website's attach option failed miserably.

The bug you claimed to have been solved with the checkbox turned off/on for optimize buffer are not working with Sun-SSH2.1.0 or any non-recent SSH unix/linux implementations.

I have scrapped WinSCP completely unfortunately from our .NET solution and using pscp.exe from PuTTY works flawlessly with any SSH 2.0 library. There are a lot of threads regarding Fatally failed errors messages for big files that occur both in the GUI and .NET assembly with the latest build(s) - tried many, including 4.x versions - from unix to windows transfers.

I wanted to offer you some help in identifying the cause. All I can say now is that the bug still exists and for machines that can't be upgraded using WinSCP will fail.

Re: .NET Assembly and WinSCP 5.1.5 Fatally Failed SCP half-way

The links to log and image do not work. I'm going to remove the links.

.NET Assembly and WinSCP 5.1.5 Fatally Failed SCP half-way


After searching, digging up old threads, trying multiple WinSCP versions, options and so on I still can't make this work:

I am trying to use the WinSCP .NET Assembly in a C# Winform App to automate the copy from some LAN UNIX Servers. However all of them mostly fail after they copied 100 of files of varying size.

I can't use the GUI version as well with optimise buffer connection on or off, same result.

log file: <removed broken link>
graphical error in winscp gui: <removed broken link>

After developing in C# to fully support WinSCP I am officially stuck. Help please!