Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Options
Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)

Options

Topic review

martin

Re: Can I just turn off logging?

Also can you test suggestion by @agriffin (post here) to set process to run in 2003 compatibility mode?
martin

Re: Can I just turn off logging?

Typically, the root cause is not a logging, it's just a manifestation of the actual problem, that WinSCP does not start. And no, you cannot turn it off, it's necessary for .NET assembly operation.

Please download Process Monitor from:
https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

When you run it, it will ask you to enter filter (if not, use filter toolbar button).
Select "Process Name", "contains", "winscp" => Add => Ok.

Then run WinSCP.

Hopefully some records about the start show up.

The go to File > Save, select "Events displayed using current filter" and PML format (both should be default).

Try to collect the log both for situation when WinSCP works and when it does not.

Email me the .pml files then.

Thanks.
gholmes

Anybody ... Bueller?
gholmes

I run it from Windows Task Scheduler once per day.

Obviously the user it runs under does have write permission ... it works some days, but not others.


Here's an example of the errors:

WITHOUT CUSTOM PATH:
6/21/2013 5:34:38 AM
System.TimeoutException: Timeout waiting for WinSCP to respond - Log file C:\Documents and Settings\Administrator\Local Settings\Temp\wscp0A68.0202C666.tmp was not created in time, please make sure WinSCP has write permissions to the folder
at WinSCP.Session.CheckForTimeout(String additional)
at WinSCP.Session.Open(SessionOptions sessionOptions)



WITH CUSTOM PATH:
6/24/2013 5:34:10 AM
System.TimeoutException: Timeout waiting for WinSCP to respond - Log file C:\WinSCP.log was not created in time, please make sure WinSCP has write permissions to the folder
at WinSCP.Session.CheckForTimeout(String additional)
at WinSCP.Session.Open(SessionOptions sessionOptions)
gholmes

Can I just turn off logging?

I'm getting the "Timeout waiting for WinSCP to respond ... unable to create in time" error.

It's intermittent. It doesn't matter whether I specify a path or not. And obviously the scheduler user *does* have write permission, since it works sometimes.

Can I just turn off logging? I just want this to plain work. Frankly, this is the only error I've been getting :) Is there a way to turn off logging, using the .NET assembly?