Post a reply

Before posting, please read how to report bug or request support effectively.

Bug reports without an attached log file are usually useless.

Add an Attachment

If you do not want to add an Attachment to your Post, please leave the Fields blank.

(maximum 10 MB; please compress large files; only common media, archive, text and programming file formats are allowed)


Topic review


Thanks for sharing your findings!

I have done a bit of digging and it looks like the fault may well lie with my ISP (BT in the UK).

There are a number of posts regarding FTP issues with their standard router (BT Home Hub - v3 in my case). It also looks like they did a remote firmware update around about the time I started having problems!

Following some guidance on one of the posts I removed the home hub from the equation and made a direct PPPoE connection and WinSCP started to work again. So I am now pretty sure the fault does not lie with WinSCP per se (although it looks like other FTP program may be a little more tolerant of whatever is going on?)

So the issue appears to be with my router and I am probably going to have to replace it or get BT to do revert the upgrade (not likely!)

I really appreciate your support and I am sorry it may have been a waste of your time.

I tried on a different PC (5.5.2 - Windows 7 Pro) with exactly the same results. It is on the same network, so using the same Internet connection ... that gave me an idea, so I tried connecting to the internet via my mobile .. and that works fine on the original PC.

So I am not sure where that leaves me - I have no other issues that I am aware of with my internet connection and as I said previously I had reset it anyway. The issue is pretty consistent, so it doesn't sound like an intermittent fault on my physical connection, and other FTP programs are working. Until about a week ago, so was WinSCP.

I am not familiar with monitoring network traffic.

Server is Windows Server 2008 R2

Any further thoughts?

Thanks. Can you connect to the server from another location/machine (using WinSCP)? What is your server software?
Do you know how to capture network traffic?

FileZilla seems to connect first time.

Here is the FileZilla console log ...

Status: Resolving address of [removed]
Status: Connecting to [removed]...
Status: Connection established, waiting for welcome message...
Response: 220-Microsoft FTP Service
Response: 220 [removed] Ltd
Command: USER [removed]
Response: 331 Password required for [removed].
Command: PASS ***************
Response: 230-Welcome to the Master FTP for [removed]! Put web documents in htdocs!
Response: 230 User logged in.
Command: OPTS UTF8 ON
Response: 200 OPTS UTF8 command successful - UTF8 encoding now ON.
Status: Connected
Status: Retrieving directory listing...
Command: CWD /[removed]/htdocs/MembersOnly
Response: 250 CWD command successful.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (109,228,1,23,228,196).
Command: LIST
Response: 150 Opening BINARY mode data connection.
Response: 226 Transfer complete.
Status: Directory listing successful

Re: Timeout Detected on Starting the Session

Please attach a full FileZilla log too. Does FileZilla connect on the first try?

Timeout Detected on Starting the Session

I have been using WinSCP for years and loved it (and contributed), but I have now got to a point where I can't use it.

WinSCP Version 5.5.2 (Build 4130) (OS 6.1.7601 Service Pack 1 - Windows 7 Professional)

Every time I try to connect (multiple different FTP servers - but all Windows based), It gets to the point where it says "Starting the session ..." and then it goes "Timeout detected". It then just keeps looping, trying to connect every 5 seconds until I cancel.

I can connect to the same FTP servers using a browser and FileZilla.

I tried reverting to an earlier version (5.05), but got the same issue. I have reset the FTP servers (where I can). I have reset my router and internet connection - but nothing gets me working again - just occasionally it will complete the connection, but as soon as I try to do something it inevitably loses the connection again.

I tried increasing the timeout, but no success and as far as I can see, the server responds immediately when I use another FTP client.

I tried Passive mode off and on, no luck.

Please help as I would like to go back to my favourite FTP client.

I have turned on the log and the relevant part seems to be ...

. 2014-03-28 07:54:56.679 Connecting to ftp.[Removed] ...
. 2014-03-28 07:54:56.737 Connected with ftp.[Removed]. Waiting for welcome message...
< 2014-03-28 07:54:56.738 220-Microsoft FTP Service
< 2014-03-28 07:54:56.738 220 [Removed] Ltd
> 2014-03-28 07:54:56.738 USER [Removed]
< 2014-03-28 07:54:56.738 331 Password required for [Removed]
> 2014-03-28 07:54:56.738 PASS ***************
< 2014-03-28 07:54:56.798 230-Welcome to the Master FTP for [Removed]! Put web documents in htdocs!
< 2014-03-28 07:54:56.798 230 User logged in.
> 2014-03-28 07:54:56.798 SYST
< 2014-03-28 07:54:56.818 215 Windows_NT
> 2014-03-28 07:54:56.818 FEAT
< 2014-03-28 07:54:56.841 211-Extended features supported:
< 2014-03-28 07:54:56.841 LANG EN*
< 2014-03-28 07:54:56.841 UTF8
< 2014-03-28 07:54:56.841 AUTH TLS;TLS-C;SSL;TLS-P;
< 2014-03-28 07:54:56.841 PBSZ
< 2014-03-28 07:54:56.842 PROT C;P;
< 2014-03-28 07:54:56.842 CCC
< 2014-03-28 07:54:56.842 HOST
< 2014-03-28 07:54:56.842 SIZE
< 2014-03-28 07:54:56.842 MDTM
< 2014-03-28 07:54:56.842 REST STREAM
< 2014-03-28 07:54:56.842 211 END
> 2014-03-28 07:54:56.842 OPTS UTF8 ON
< 2014-03-28 07:54:57.793 200 OPTS UTF8 command successful - UTF8 encoding now ON.
. 2014-03-28 07:54:57.811 Connected
. 2014-03-28 07:54:57.811 --------------------------------------------------------------------------
. 2014-03-28 07:54:57.811 Using FTP protocol.
. 2014-03-28 07:54:57.812 Doing startup conversation with host.
> 2014-03-28 07:54:57.864 PWD
. 2014-03-28 07:55:12.557 Timeout detected.
* 2014-03-28 07:55:12.614 (EFatal) **Lost connection.**
* 2014-03-28 07:55:12.614 Timeout detected.